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CamCor EZ-Link  
Software User Manual
Section 1—Getting Started
CamCor* EZ-Link* software (EZ-Link) allows you to configure and maintain CamCor 
Coriolis meters remotely using a personal computer (PC) via a Highway Addressable 
Remote Transmitter (HART) modem. 

Note EZ-Link is optimized for use with HART modems supplied by Cameron. Users 
wishing to provide their own modem(s) are responsible for verifying compatibility 
with EZ-Link. 

Unless otherwise noted, Cameron highly recommends using the most current 
version of EZ-Link software, which provides latest product functionality. 

INSTALLING THE MODEM
1. Using the wiring instructions in the CamCor Coriolis Hardware manual, wire the modem

to the CamCor meter.

2. Following the manufacturer’s instructions, install the modem’s driver from disk or web
browser. Verify communications per manufacturer’s recommendation.

3. Plug the modem cable into the PC port used to interface with the meter.

4. Identify the port number assigned to the modem as follows.

a. From the computer’s Start menu, browse to the Control Panel and open the
Device Manager.

b. Select Ports (COM & LPT) and record the COM number assigned to the modem.

c. Close the Device Manager.

ESTABLISHING COMMUNICATIONS WITH THE DEVICE
1. To open EZ-Link, click on the desktop shortcut (Figure 1.1) or browse to the program

from your computer’s Start menu.

Figure 1.1—EZ-Link desktop shortcut

The EZ-Link workspace will appear as a gray rectangle with a toolbar at the top.

Note EZ-Link software opens in full-screen mode. Grab any corner and drag to resize 
the software interface.

2. Select File>Port Settings, as shown in Figure 1.2, page 2.
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The communication 
status (bottom left of 
screen) will change 
depending on the 
menu selection.

Figure 1.2—EZ-Link workspace and File menu

3. The Port Setting dialog (Figure 1.3) will appear. Select the port assigned to the modem
connection and click OK.

IMPORTANT If EZ-Link does not automatically detect the active communication link  
with the transmitter, the communication in the bottom left corner will  
display “CLOSE” or appear blank (no message). The blank area appears 
when EZ-Link has not yet attempted to connect to the transmitter.

Figure 1.3—Port Setting dialog

4. Choose File>Connect. The Connect dialog will appear (Figure 1.4), prompting the se-
lection of a HART polling address. EZ-Link’s default HART polling address is “0.” Click
OK to accept the default setting.

If your transmitter has a different polling address, select the appropriate address from
the dropdown menu and click OK. The “0-15” and “0-63” options will sequentially
search within the specified range and connect to the first meter that responds. The
Custom selection allows you to address a specify HART polling address.

Figure 1.4—Connect dialog

Accessing Toolbar Options
Each toolbar tab expands to display 
a list of menu options. Available 
options are displayed in black text 
and unavailable actions are grayed 
out. To establish communications 
with the transmitter, select 
File>Connect. Upon connection, 
the grayed-out tabs, such as 
Process Variables, will be listed in 
black text, indicating they are active  
options.

Communication Status Indicator
Communication status is displayed 
in the bottom left of the window. 
Status messages such as Idle, 
Communicating-Please Wait, 
Close, etc., may appear. If the PC 
is unable to communicate with the 
meter, check the status for help 
diagnosing issues.
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The Connect dialog will display a progress bar as the software attempts to connect to 
the transmitter. Upon connection, you will receive a confirmation message. Follow the 
screen prompts to proceed.

GENERAL NAVIGATION
The EZ-Link software interface allows multiple windows to be opened simultaneously. See 
Windows Menu, page 39 for more information about sorting multiple windows.

Onscreen Buttons

OK buttons are associated with multiple operations. Clicking OK may accept a change, exit 
a window, begin a test or function, or acknowledge a message box.

Close buttons are used to exit a screen and/or cancel a text entry.

GENERAL/ADMINISTRATIVE FUNCTIONS (FILE MENU)
The File menu is the gateway to interacting with your meter. From this menu, you can

• Connect to (or disconnect from) a meter
(File>Connect; File>Disconnect)

• Open, save, delete, or upload configuration files
(File>Configuration)

• Print a configuration summary report

• Configure communication port settings (File>Port
Settings)

Exit the software by choosing File>Disconnect. Once the software is disconnected from 
the device, choose File>Exit or click the red “×” in the upper right of the screen.

Configuration File and Summary

To save a meter configuration file, select File>Configuration>Save File and click OK in 
the Download dialog. By default, the configuration settings will download to  
C:\Cameron Data\CamCor EZ-Link(E)\Downloads. 

To view the formatted Meter Configuration report onscreen, select File>Configuration> 
Save File and click OK in the Download dialog. A preview of the report (Figure 1.5) will 
appear. If your PC is connected to a printer, click Print to print a copy.

Figure 1.5—Print preview sample report

Closing the Active Window
To quickly close the active window, 
press ESC on the keyboard.

Opening a Previously Saved File
To open and/or print a previously 
saved configuration file, select File> 
Configuration>Open File and 
navigate to the desired file.
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Section 2—Configuring the Device with EZ-Link
         To configure the device using EZ-Link software, establish a  
         connection with the meter using the instructions in Section 1, 
         then select the Setup menu in the main toolbar and choose 

the item(s) to be configured from the dropdown menu. 
 

Caution  If the flowmeter outputs are used to control valves or other systems, 
place the control loop in Manual Control mode to isolate the transmit-
ter signal before changing the flowmeter configuration. Failure to do 
so may produce unexpected valve behavior or damage to the system. 
Additionally, potential safety and environmental hazards may occur.  
 
When changing the meter configuration, the analog/pulse outputs may 
become erratic or momentarily go to zero state before recovering. Af-
ter the configuration is updated, the transmitter will operate normally. 
Refer to the CamCor Coriolis Hardware Manual for details.

DEVICE VARIABLES
To change the basic configuration of flow, density, and temperature variables, click 
Setup>Device Variables. The Device Variables Setup screen (Figure 2.1) will appear.

Change the transmitter configuration using the dropdown menus, radio buttons, and value 
fields. Click OK to apply the changes.

Figure 2.1—Device Variables Setup dialog

FLOW DIRECTION
If the flow direction is Forward, the 
arrow direction on the front of the 
meter is treated as the positive 
direction. If the flow direction is 
Reverse, the opposite direction 
from the arrow on the meter is 
treated as the positive direction.

Why is some onscreen text blue?
Onscreen text appears blue 
when the variable value or unit 
of measure can be changed from 
the Device Variables Setup dialog 
within the software.
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See the CamCor Coriolis Hardware Manual for help in determining suitable settings for the 
parameters on the Device Variables Setup screen. 

Default settings for Device Variables Setup parameters and allowable ranges are provided 
in the Table 2.1:

TABLE 2.1—DEVICE VARIABLE SETUP
PARAMETER UNIT(S) RANGE DEFAULT

Flow Rate Damping seconds 0 to 200 0.8

Flow Rate Cutoff % of sensor upper 
limit

0.000 to 5.000 0.500

Volume Flow Rate Meter 
Factor

— – 999999 to 999999 1.0

Density Damping seconds 0.0 to 200.0 4.0

Slug Flow Low Limit g/mL 0.0000 to 10.0000 0.0 (gas) 
0.3 (liquid)

Slug Flow High Limit g/mL 0.0000 to 10.0000 2.0

Slug Flow Duration seconds 0 to 60 0

Manual Density 
Compensation

— ON or OFF OFF

Fluid Base Temperature degC – 273.15 to 999.99 degC
(– 459.67 to 1,831.982 degF)

20 degC 
(60 degF)

Fluid Expansion Coefficient (g/mL)/degC – 999999 to 999999 0.00024

Density Source — Override or Live Live

Override Value g/mL 0.0000 to 5.0000 1.0000

Temperature Unit deg degC, degF, Kelvin, degR degC

Temperature Damping seconds 0.0 to 200.0 2.5

OUTPUTS
            CamCor meters support the following 

outputs:

• Two analog outputs

• Two pulse outputs

• One status output (assignable to  
       status information, flow direction,  
       high/low alarm state, or drive gain        
 alarm state)

Note EZ-Link software includes a loop check function for validating output signal. For 
details, see Loop Test, page 26. EZ-Link also includes Simulated Outputs, page 
36 that allow you to enable simulated conditions to check output scaling.

Assigning Analog and Pulse Outputs

IMPORTANT Modifying the Pulse Output will reset the corresponding Counter/Totalizer.

Before beginning configuration, read the Caution statement on page 4. To assign a 
parameter to an analog output or pulse output, 

1. Click Setup>Outputs>Analog/Pulse Assignment and select the desired parameter 
from the dropdown menu provided in the Analog/Pulse Assignment dialog (Figure 2.2, 
page 6).

Flow Rate Cutoff Calculation
Flow Rate Cutoff is expressed 
as a percentage of the sensor 
upper limit. EZ-Link indicates the 
corresponding value in the user-
selected mass flow rate units.

The Flow Rate Cutoff is used to 
prevent the meter from falsely 
indicating flow at zero-flow 
conditions. When flow decreases 
below the Flow Rate Cutoff, flow 
rate indication and any flow rate-
associated outputs return a “0.”

The cutoff is activated when Flow 
Rate Cutoff % = (Current Flow 
Rate)/Sensor Upper Limit) * 100.
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Figure 2.2—Analog/Pulse Assignment dialog

2. Click OK. A warning (Figure 2.3) will appear. 

Figure 2.3—Analog/Pulse Assignment warning

3. After taking appropriate cautionary action, click OK to acknowledge the Analog/Pulse 
Assignment warning. 

4. When the configuration change has been applied successfully, a Configuration Up-
dated notice (Figure 2.4, left) will appear. Click OK to acknowledge. 

Note If changes to the analog/pulse assignment result in out-of-range analog/pulse 
output(s), the transmitter will detect the Range Value Error. In this case, the notice 
will indicate the Range Value Error (Figure 2.4, right). Review and correct the con-
figuration to eliminate the error condition.

.         
Figure 2.4—Configuration Updated notice (left) and Range Value Error notice (right)

5. If a control system was placed in Manual mode prior to the configuration change and 
you are finished configuring the output, you can return the control system to Auto 
mode.

Configuring an Analog Output

Analog outputs can be assigned to instantaneous mass flow rate, instantaneous volume 
flow rate, density, temperature, and drive gain. Before beginning configuration, read the 
Caution statement on page 4. To configure an analog output, 

1. Assign the desired parameter to the output as described in Assigning Analog and Pulse 
Outputs, page 5.

2. Click Setup>Outputs>Analog (1 or 2).

Returning to Auto Mode
Before returning to Auto Mode, 
Cameron recommends completing 
all configurations to avoid 
unnecessary switching between 
Manual and Auto Mode.
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Figure 2.5—Analog Output 1 dialog

3. Enter upper and lower range values. The span required depends on the operating
conditions. Entries must be between the Sensor Upper Limit and Sensor Lower Limit,
as shown in Figure 2.5.

4. If a flow rate is assigned to the output, enter a low cutoff (0% to 10%).

5. Enter additional damping, if desired (0 to 200 seconds). Select a larger value when ana-
log output fluctuates greatly; select a smaller value when a fast response is required.

6. Click OK on the Analog Output 1 screen and on subsequent dialogs to save the settings
and acknowledge the configuration change.

Configuring a Pulse Output

Pulse Output 1 can be assigned to instantaneous mass flow rate or instantaneous 
volume flow rate. The two pulse outputs on the transmitter can be configured to function 
independently or together in Double Pulse mode. The pulse outputs can be configured to 
Bidirectional Mode using the Status Output. Bidirectional mode indicates flow direction to 
secondary devices and affects the CamCor pulse counters and flow totalizers.

IMPORTANT Modifying the Pulse Output will reset the corresponding Counter/Totalizer.

Pulse Output 1 and Pulse Output 2 have the same configuration options; however, Pulse 
Output 2 also offers Double Pulse mode. The instructions below apply to both pulse outputs.  
See Double Pulse Mode, page 8 for information about configuring the Double Pulse 
mode.

IMPORTANT Before beginning configuration, read the Caution statement on page 4.

Pulse Operation Mode

Note The Pulse Operation Mode selected is applied to Pulse Output 1 and Pulse Output 
2.

Choose Setup>Outputs>Pulse Operation Mode and select from the following Pulse 
Output modes:

• Pulses per Unit. Pulses are output according to the specified number of pulses per unit
and the current flow rate.

• Rate and Frequency Factors. Pulses are output according to the specified frequency
factor, rate factor, and low cutoff.

After selecting the Operating Mode, follow the applicable instructions below.

Pulse Output: Pulses per Unit
To use a pulse output in Pulses per Unit mode, configure as follows:

1. Verify that the Pulse Operation mode is set to Pulses per Unit.

2. Navigate to Setup>Outputs>Pulse Output (1 or 2) and enter the pulses per unit in the
field provided (Figure 2.6, page 8).

Analog Output Low Cutoff
The Low Cutoff setpoint is 
determined by the relationship 
between the Low Cutoff percentage 
value and Analog Output span.

If density, temperature, or drive 
gain are assigned, Cameron 
recommends setting to 0%, which 
disables the cutoff.

If the mass flow or volume flow is 
assigned, Cameron recommends 
to set Lower Range to “0” to ensure 
proper operation of the Low Cutoff.

For convenience, when you enter 
the Low Cutoff in percentage, the 
screen also displays the value in 
the corresponding user-selected 
units.

Analog Output Level (%) = (Sensor 
reading – Low Range) / (Upper 
Range – Low Range) * 100.
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Figure 2.6—Pulse Output 1, Pulses per Unit dialog

3. Click OK on the Pulse Output 1 dialog and on all subsequent dialogs to save the set-
tings and confirm the configuration change.

Pulse Output: Rate and Frequency Factors
To use a pulse output in Rate and Frequency Factors mode, configure as follows:

1. Verify that the Pulse Operation Mode is set to Rate and Frequency Factors.

2. Navigate to Setup>Outputs>Pulse Output (1 or 2) and set the following parameters, 
using Figure 2.7 as a reference:

Figure 2.7—Pulse Output 1, Rate and Frequency Factors

a. Frequency Factor. The pulse output frequency when the flow rate is equal to the 
flow rate value specified in step 2b. Acceptable setting range is 0.1 Hz to 10,000 
Hz. If the assigned flow rate (%) drops below the low cutoff, the pulse output 
frequency will be 0 Hz.

b. Rate Factor. The flow rate at which the Frequency Factor (2a) will be output. The 
rate factor should be set to a value less than the upper range limit of the meter. 
See the CamCor Coriolis Hardware Manual for more details.

c. Low Cutoff. The low cutoff value, expressed as a percentage of the value 
specified in the rate factor (2b). The transmitter will compare the current flow rate, 
rate factor, and low cutoff to determine the Low Cutoff setpoint. If you set the low 
cutoff to 0%, the low cutoff function will be disabled.

3. Click OK on the Pulse Output 1 dialog and on subsequent dialogs to save the settings 
and acknowledge the configuration change.

Double Pulse Mode
When a Double Pulse mode is assigned to Pulse Output 2, the detailed configuration of 
Pulse Output 2 will be disabled and automatically adjusted to have the same configuration 
as Pulse Output 1. Therefore, both outputs will produce the same frequency in a different 
phase. The Double Pulse mode selected for Pulse Output 2 will determine the phase shift 
between the two signals. 

Double Pulse Output Settings
Select one of the three Double Pulse modes from the following, referring to Figure 2.8, page 
9 for examples of each setting:

Frequency Optimization
To maximize Pulse Output 
resolution, set the Pulses per Unit 
or the Frequency Factor and Rate 
Factor to produce the maximum 
number of pulses per unit, ensuring 
that the actual maximum flow rate 
through the meter will not cause the 
frequency output to exceed 10,000 
Hz. The signal will be truncated at 
11,000 Hz.

Pulse Output Low Cutoff
The Low Cutoff setpoint is 
determined by the relationship 
between the Low Cutoff percentage 
and the Current Flow Rate.

Low Cutoff (% of Rate Factor) = 
Current Flow Rate/ (Rate Factor) * 
100. 

For convenience, the Low Cutoff is 
displayed in the user-selected units

8



Pulse out 1

Pulse out 2

Pulse out 1

Pulse out 2

Pulse out 1

Pulse out 2

 90°
(1/4 of the period)

90°
(1/4 of the period)

DOUBLE PULSE 90°

DOUBLE PULSE –90°

DOUBLE PULSE 180°

Fast Pulse Output (> 250 Hz)

Figure 2.8—Double Pulse Output mode signal example (Frequency = 250 Hz)

• Double Pulse – Pulse Output 1 90° Shift. Pulse Output 1 leads Pulse Output 2 by 
90°. The phase shift between pulse signals is the smaller of 90° (1/4 of the period) or 1 
msec.

• Double-Pulse – Pulse Output 1 180° Shift. Pulse Output 1 and Pulse Output 2 are 
the same signals with the polarity of the signals inverted.

• Double-Pulse – Pulse Output 1 –90° Shift. Pulse Output 2 leads Pulse Output 1 by 
90°. The phase shift between pulse signals is the smaller of 90° (1/4 of the period) or 1 
msec.

Configuring the Status Output

IMPORTANT Before beginning configuration, read the Caution statement on page 
4.

To configure the status output, 

1. Click Setup>Outputs>Status Output and choose one of the five functions in the 
Status Output dialog. Other than “Disabled,” the remaining four selections are:

• Error/Alarm/Status. Status output 
changes state when the condition of 
the assigned error, alarm or status 
are changed.

• Bidirectional. Status output changes  
 state to the bidirectional mode,  
 in which the flow rate for “Forward”  
 (positive) and “Reverse” (negative)  
 flow directions are monitored. The  
 status output state changes when  
 the flow direction detected by the  
 transmitter changes.

• High/Low Alarm. Status output  
 changes state in response to flow  
    change directions. The transmitter  
    accumulates pulse count and  
    flow total in “Forward” (positive) and  
    “Reverse” (negative). It also  
    calculates a net total as follows:  
    (Forward) – (Reverse) = Net.

• Drive Gain Alarm. Status output  
changes state when the transmitter 
drive gain crosses the user-specified 
threshold. 

Maximum Phase Shift
The maximum phase shift for Pulse 
Output 1 ± 90° is 1 msec. When the 
period of the Pulse Output 1 signal 
is > 4 msec, the phase shift might 
be < 90° (1/4 of the period). In such 
case, the phase shift will be fixed at 
1 msec.

Status Output
Status output form is open collector. 
The status output should be used 
with an external pullup resistor. 
See the CamCor Coriolis Hardware 
Manual for more information.

Status Output: Disabled Mode
When you select “Disabled” mode, 
the status output remains as 
follows:
• Normally Open mode = Open

• Normally Closed mode = Closed

Drive Gain Alarm
The drive gain is adjusted 
continuously to control the sensor 
tube frequency. Determine the 
“normal” drive gain values by 
monitoring the flowmeter under 
normal flowing conditions. 

Setting the Drive Gain Threshold 
at a point above the maximum 
“normal” drive gain allows you to 
detect abnormal process conditions 
and system disturbances.

Configuration for the Drive Gain 
Threshold (%) is calculated as 
follows:

Drive Gain Threshold (%) = Desired 
Drive Gain Threshold (V) / 60 * 100.

For example, to set the Drive Gain 
threshold at 45 V, enter a value of 
75%.
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2. If the selected status output function is Error/Alarm/Status, you can assign multiple 
parameters to the Status Output. If any parameter condition is “active,” the Status 
Output state will change. You can set multiple parameters to “Assigned;” however, you 
will be unable to distinguish which parameter(s) caused the change of state because 
there is only one Status Output. To determine which parameter(s) are “active,” access 
the transmitter display or establish digital communications with the transmitter. Table 
2.2, page 10 defines activation conditions for each selection.

3. To configure the active output state, select the desired output mode (Normally Open 
or Normally Closed) in the “Status Output Mode” field at the bottom of the dialog. The 
default setting is Normally Closed.

4. Click OK on the Status Output dialog. A warning (Figure 2.9) will appear. After taking 
appropriate cautionary actions, click OK to apply the change. 

Figure 2.9—Status Output, Apply New Configuration warning

5. When the configuration change has been applied, a confirmation dialog will appear. 
Click OK to acknowledge the change. Switch system controls back to Auto mode if 
applicable.

 

TABLE 2.2—STATUS OUTPUT ERROR OPTIONS1

OPTION2 DESCRIPTION CONDITION
Error - Sensor Sensor error Activated when the drive gain and temperature 

sensor readings are outside the normal range or 
when the parameters are outside the sensor limits.

Error - Transmitter Transmitter error Activated when the transmitter detects data errors 
during internal operations.

Error - Calibration Calibration error Activated when the result of the last “Auto Zero” 
calibration is “Fail.”

Alarm - Output 
Overrange

Output Overrange 
alarm

Activated when the analog outputs or pulse outputs 
are outside the designated output range. For analog 
output, the output range is –10% to 110%. For pulse 
output, the output range is 0% to 110%.

Alarm - Parameter Parameter alarm Activated when the Analog Output Range values or 
High/Low Alarm setpoints return invalid values.

Alarm - Transmitter Transmitter alarm Activated when the internal temperature exceeds 
the maximum operating temperature range (90° C or  
194° F)

Alarm - Slug Flow Multiphase flow 
alarm

Activated when the density stays outside the normal 
range for a specified amount of time.

Status - Calibration 
in Progress

Calibration in 
progress

Activated when the transmitter performs the Auto 
Zero calibration.

Status - Manual 
Output

Output overridden Activated when analog outputs, pulse outputs, 
or status output are overridden. Triggered by 
Loop Test, Override Status Output, 0% Signal 
Lock, or Loop Current Mode (HART multidrop 
communication).

1.   Status output works as an error if the “Status Output Function” is set to “Error/Alarm/Status.”
2.  See the CamCor Coriolis Hardware Manual for detailed descriptions of of each  
     error, alarm, or status.

Configuring an Error/Alarm Output Value

The Error/Alarm Output function controls the Analog 1/2 and Pulse 1/2 output signals 
when a sensor error, transmitter error, or parameter alarm is detected. When active, the 
transmitter outputs the user-specified signals. To configure the Error/Alarm Output signal 
levels,

Status Output Error/Alarm/Status 
Function
The user-specified parameters will 
be monitored. Any active “Assigned” 
condition will trigger the Status 
Output state to “Active.”. 

Returning to Auto Mode
Before returning to Auto Mode, 
Cameron recommends completing 
all configurations to avoid 
unnecessary switching between 
Manual and Auto Mode.

Output Overrange Alarm
When the Output Overrange alarm 
is detected, the reading from 
the monitoring device might be 
truncated as follows:

Analog Output = 2.4 mA (displayed 
as –10%) or 21.6 mA (displayed as 
110%)

Pulse Output = 11 kHz
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1. Click Setup>Outputs>Error/Alarm Output Value. and select the desired default out-
put signal(s) from the Output When in Error/Alarm Output Value dialog (Figure 2.10). 
Table 2.3 details the available options.

  
Figure 2.10—Error/Alarm Output Value dialog [Analog (green) and Pulse (blue) dropdown 
menus]

TABLE 2.3—ERROR/ALARM OUTPUT VALUE OPTIONS
OPTION ANALOG OUTPUT PULSE OUTPUT

Downscale 2.4 mA —

Zero  4 mA 0 Hz

Hold Last Last good output value  
before the error

Last good output value  
before the error

Upscale 21.6 mA 11,000 Hz

2. Click OK. A Configuration Update warning (Figure 2.11) will appear.

3. After taking appropriate cautionary action, click OK to apply the change(s).

Figure 2.11—Configuration Update warning

Caution If the flowmeter outputs are used to control valves or other systems, 
place the control loop in Manual Control mode to isolate the transmit-
ter signal before changing the flowmeter configuration. Failure to do 
so may produce unexpected valve behavior or damage to the system. 
Additionally, potential safety and environmental hazards may occur.  
 
When changing the meter configuration, the analog/pulse outputs may 
become erratic or momentarily go to zero state before recovering. Af-
ter the configuration is updated, the transmitter will operate normally. 
Refer to the CamCor Coriolis Hardware Manual for details.

4. When the configuration change has been applied, a confirmation dialog will appear. 
Click OK to acknowledge the change. If applicable, switch system controls to Auto 
Mode. 

Hold Last Option
The Hold Last option retains the 
last good output value before the 
Error/Alarm Output Value function is 
activated or before a Sensor Error, 
Transmitter Error, and Parameter 
Alarm is detected.

Returning to Auto Mode
Before returning to Auto Mode, 
Cameron recommends completing 
all configurations to avoid 
unnecessary switching between 
Manual and Auto Mode.
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STATUS INPUT 
In addition to the “Disabled” (no function) Status Input Function, you can configure he status 
input perform any of the following actions:

• 0% signal lock. The transmitter
locks values to 0% (analog outputs =
4 mA; pulse outputs = 0 Hz).

• Auto zero. The transmitter begins
the Auto Zero Calibration process.

• Reset cumulative totals. The
transmitter resets Counter/Totalizer
1, Counter/Totalizer 2, or both.

The status input can be configured to perform the selected function when the status input 
changes state, as shown below. 

By default, the status input mode is “Normally Open:”

• Normally Open. The transmitter performs the assigned function when the status input
terminal is Closed for a minimum of 0.3 seconds. This mode is intended for use with the
Normally Open (Form A) contact.

• Normally Closed. The transmitter performs the assigned function when the status input
terminal is Open for a minimum of 0.3 seconds. This mode is designed for use with the
Normally Closed (Form B) contact.

The following sections provide more information about each Status Input Function. Access 
the Status Input dialog by selecting Setup>Status Input. 

0% Signal Lock

When active, the analog output and pulse output signals are fixed at 0% (4 mA for analog 
outputs and 0 Hz for pulse outputs. The transmitter continues the 0% Signal Lock until the 
status input state changes to “Inactive.”

To configure the 0% Signal Lock status input function, 

1. In the “Status Input Function” field, select 0% Signal Lock.

2. In the “Status Input Mode” field, select the desired status input mode.

3. Click OK on the dialog and on subsequent dialogs to save the settings and confirm
the configuration changes. If applicable, take appropriate precautionary actions before
clicking OK.

Auto Zero (Zero Adjustment)

When active, the transmitter initiates an Auto Zero calibration, which minimizes the offset 
flow rate drift. For additional information about zero adjustment calibration, see Auto Zero, 
page 28. To configure the zero adjustment (Auto Zero) status input function, 

1. In the “Status Input Function” field, select Auto Zero.

2. In the “Status Input Mode” field, select the desired status input mode.

3. Click OK on the dialog and on subsequent dialogs to save the settings and confirm
the configuration changes. If applicable, take appropriate precautionary actions before
clicking OK.

Reset Counters/Totalizers (1, 2)

The CamCor transmitter is equipped with two counter/totalizer accumulation units that are 
synchronized with the pulse outputs.  Counter/Totalizer 1 corresponds to Pulse Output 1 
and Counter/Totalizer 2 corresponds to Pulse Output 2. When the status input is active, the 
transmitter resets the selected Counter/Totalizer(s) to “0.”

To configure the Reset Counter/Totalizer status input function, 

Status Input and Write Protection
When Write Protection is enabled, 
changes to the status input function 
cannot be executed, even if the 
Status Input becomes “active.” See 
Viewing Write Protection Status, 
page 19 for more information.

Counter/Totalizer and Pulse 
Output
The pulse count and flow totalizer 
accumulations reflect the user-
selected units of measure and 
pulse output assignment (mass or 
volume).

The Counter represents the 
number of pulses generated 
and the Totalizer represents the 
accumulated mass or volume units. 
These accumulate according to the 
flow direction and the bidirectional 
option selected, if any.
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1. In the “Status Input Function” field, select Reset Counters/Totalizers 1 and 2, Reset 
Counter/Totalizer 1, or Reset Counter/Totalizer 2.

2. In the “Status Input Mode” field, select the desired status input mode.

3. Click OK on the dialog and on subsequent dialogs to save the settings and confirm 
the configuration changes. If applicable, take appropriate precautionary actions before 
clicking OK.

HIGH/LOW ALARMS
When active, the high/low alarms indicate to operators that a parameter, such as flow rate, 
temperature, density, or flow total value, is outside the setpoint for that parameter. When 
alarm conditions are met, the high/low alarm state will change to “active.” To configure a 
high, low, or high/low alarm,

1. Select Setup>Outputs>Status Output and set the “Status Output Function” to High/
Low Alarm. Set the “Status Output Mode” to Normally Open or Normally Closed. For 
more information, see Configuring the Status Output, page 9.

2. Select Setup>High/Low Alarm>Alarm Assignment and choose from the dropdown 
menu to the right of “High/Low Alarm Assignment.” Options are

 – Mass Flow Rate (Instanteous)  – Volume Flow Rate (Instanteous)
 – Density  – Temperature
 – Counter 1  – Counter 2

3. Click OK on the dialog and on subsequent dialogs to save the settings and confirm 
the configuration changes. If applicable, take appropriate precautionary actions before 
clicking OK. 

4. Select Setup>High/Low Alarm>Alarm Parameters and select the alarm type from 
the list:

    

• High Alarm. 
Validate the high 
alarm only.

• Low Alarm. 
Validate the low 
alarm only.

• High/Low Alarm. 
Validate the high 
and low alarms.

5. Enter the appropriate setpoint value(s) (high, low, or high/low) in the “Alarm Setpoint” 
field(s) provided. If the input exceeds the high setpoint when a high alarm is configured 
or drops below the low setpoint when a low alarm is configured, the corresponding 
alarm will be activated.

6. To reduce the risk of an alarm being triggered repeatedly by an input that travels errati-
cally in and out of the configured setpoint range, enter an alarm deadband in the field 
provided. This setting determines the “dead” zone following an alarm. For measure-
ments that fluctuate greatly, set a larger value. For rapid recovery from an alarm condi-
tion, enter a lower value. See the example below (Figure 2.12) for further clarification.

7. Click OK on the dialog and on subsequent dialogs to save the settings and confirm 
the configuration changes. If applicable, take appropriate precautionary actions before 
clicking OK.

Counter/Totalizer Reset
Counters and totalizers are reset 
simultaneously by design. Counters 
cannot be reset independently of 
totalizers.

Status Output Function
To use the Status Output signal 
as a High/Low Alarm indicator, the 
Status Output function must be set 
to High/Low Alarm, even in cases 
where only the high alarm or low 
alarm will be used. See Configuring 
the Status Output, page 9 for 
instructions on setting the Status 
Output function.

High/Low Alarm Values
If only one alarm type is selected, 
the Alarm Setpoint field for the 
selected alarm (high or low) will 
be editable. If High/Low Alarm is 
selected, enter values in both fields.
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High/Low Alarm Example
For the graph below, the following settings were chosen:

• Status output assignment (Function): High/Low Alarm

• Status output when inactive (Mode): Normally Open

• High/Low alarm assignment (Assign): Mass Flow Rate

• Alarm type (High/low):   High/Low Alarm

• High alarm:    800 kg/min

• High alarm setpoint – deadband: 700 kg/min

• Low alarm setpoint + deadband: 300 kg/min

• Low alarm:    200 kg/min

• Alarm deadband:   100 kg/min
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Figure 2.12—High/low alarm graph

DEVICE INFORMATION
The Device Information screen displays user-configurable device information, flange 
specifications, sensor model, sensor material, and other firmware revision (read-only), 
software, communications, and hardware information.

LCD DISPLAY
From the LCD Display menu, you can customize the appearance of the LCD as follows: 

• Change the order in which scrolling  
 parameters appear

• Adjust the screen refresh rate

• Select the character size

• Set decimal positions

• Set the backlight timeout duration

• Adjust the LCD contrast
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Configuring the Scroll Sequence

To change the order in which values appear 
onscreen, choose Setup>LCD Display>Scroll 
Sequence. From the LCD Scroll Sequence 
dialog, assign numbers 1 through 10 to the 
variables to designate the display order  
(1 = first, 10 = last). Assign “0” to remove a 
parameter from the scroll sequence. No single 
number (except 0) can be assigned to more 
than one variable. Click OK to save changes or 
Close to exit without saving.

Setting the Display Refresh Rate

To increase or decrease the screen refresh 
rate, choose Setup>LCD Display>Refresh 
Rate. From the LCD Display Refresh Rate 
dialog, select a time from 100 ms (fastest) to 
2000 ms (slowest). Click OK to save changes 
or Close to exit without saving.

Configuring the Character Size

To change the size of characters on the display, choose Setup>LCD Display>Character 
Size. From the LCD Display Character Size dialog, choose Medium (3 Variables) or Large 
(2 Variables). “Large” increases the onscreen character size and reduces the parameters 
displayed on a single screen to two. “Medium” decreases the onscreen character size, 
enabling three parameters to be displayed simultaneously. Click OK to save changes or 
Close to exit without saving.

Configuring Decimal Positions

To select the number of decimal places for mass and volume flow rates, density, and net 
totals, choose Setup>LCD Display>Decimal Position. Click on the dropdown menu 
to the right of the desired parameter and select from Auto or up to four decimal places 
(0.0000). Click OK to save changes or Close to exit without saving.

Establishing the Backlight Timeout

By default, the display backlight feature will timeout five minutes after activation. To change 
the backlight time-out setting, choose Setup>LCD Display>Backlight Timeout, click in 
the dropdown menu to the right of “Sleep After,” and select 5, 10, 20, or 30 minutes. To 
disable the timeout feature and leave the backlight on or off continuously, choose Always 
Off or Always On. Click OK to save changes or Close to exit without saving.

Configuring the LCD Contrast

To set the display contrast, choose Setup>LCD Display>Contrast. On the LCD Contrast 
dialog, either click on the selection arrow and slide left for less contrast or right for more 
contrast. Alternatively, enter a number between 1 and 63 in the “Contrast” field with 1 being 
the lightest (no contrast) and 63 being darkest (maximum contrast). Click OK to save 
changes or Close to exit without saving.

INFRARED SENSORS
The infrared sensors located on the faceplate of the transmitter allow you to navigate 
through screens and configure the meter. EZ-Link software enables you to adjust the 
sensitivity of the sensors for optimal performance. To prevent unauthorized personnel from 
changing the configuration, EZ-Link allows you to disable configuration changes from the 
transmitter faceplate, while still allowing personnel to review parameters via the LCD menu. 

To change the configuration of the infrared sensors using EZ-Link software, choose 
Setup>Infrared Sensors. The Infrared Sensor dialog will appear. 

To adjust the sensitivity of the sensors, click the “Left Sensor Sensitivity” or “Right Sensor 
Sensitivity” pointer and drag it along the bar, or enter a value between 1 (minimum 
sensitivity) and 32 (maximum sensitivity) in the fields provided.

Contrast Recommendations
When the contrast is being set 
remotely, Cameron recommends 
doing so with the device in place 
and an operator looking at the 
display and providing feedback.

Sensitivity Tips
When adjusting the infrared sensor 
sensitivity, keep in mind the location 
of the Coriolis meter, the foot traffic 
near the transmitter, and any wildlife 
in the area. Cameron recommends 
setting the infrared sensor to 
respond to direct touch. Avoid 
setting the sensitivity so high that 
the infrared sensor can be activated 
unintentionally.
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To disable field device configuration via the LCD menu, click the ON button to the right of 
“Disable Meter Configuration via LCD Sensors.” The sensors will allow you to navigate the 
menus and view current settings, but will display “Key Protect” when you attempt to change 
a setting.

HART COMMUNICATIONS

Configuring the HART Polling Address

The default HART polling address for each CamCor flowmeter is “0.” To change the polling 
address (for example, if there is more than one meter in use), choose Setup>HART 
Polling Address. The HART Communication dialog (Figure 2.13) will appear.

Figure 2.13—HART Communication dialog

Enter the desired HART polling address (0 to 63) in the field provided. If more than one 
meter will be multidropped into the same network, set a unique HART polling address for 
each meter to avoid duplicate polling addresses.

HART communications are carried over the Analog Output 1 terminals. “Enabled” mode 
is used for point-to-point communications, allowing Analog Output 1 to track an assigned 
parameter and output a proportional analog signal to a host device. HART digital  
communications are connected across the same terminals. “Disabled” mode is used for 
multidrop communications, where Analog Output 1 is forced to 4 mA, thereby disabling the 
tracking of any parameter.

False Detection
Due to the presence of objects 
within the sensor detection range, 
the sensors may be unintentionally 
activated.  Enable Prevent 
False Detection to mitigate this 
unintentional actuation. 

Hart Polling Address
When the transmitter is in point-to-
point mode, only one HART device 
can be on the signal cable pair. The 
HART polling address can remain 
“0,” the default address.  

However, when more than one 
HART device will be connected 
on the same signal loop in Multi-
drop mode, each device must 
have a unique polling address to 
communicate with the host.
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Section 3—Logging and Viewing Process Data

PROCESS VARIABLES
The options from Process Variables menu (left) provide 
instantaneous readings from the transmitter for viewing 
and logging measurements and checking the write 
protection switch status. If write protection is enabled, 
configuration changes cannot be made via any method, 
including EZ-Link software.  

Process variables are divided into two groups (Device 
Variables 1 and 2). The variables contained within each 
group are defined below.

Viewing Device Variables

Device Variables 1
     Select Process Variables>Device Variables 
     1 to view

• Flow rates (mass and volume)

• Density

• Temperature

• Counter/Totalizers (1 and 2)

• Analog Outputs in % (1 and 2)

If notable events, such as alarms or errors, 
are detected, they will be displayed in blue 
or red text at the bottom of the screen, as 
shown in the figure to the left.

Device Variables 2
Select Process Variables>Device 
Variables 2 to view 

• Left and right pickoff coil amplitude

• Drive frequency, period, and gain

• Phase differential

• Temperature

 – Sensor tube (CT and PRO Series)

 – Sensor body (PRO Series only)

 – Differential (Pro Series only) 

• Raw density 
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Viewing Charts and Data Logging

Select Process Variables>Charts and Data Logging>Active to view real-time charts or 
perform data logging. Process variables for charting and data logging are: flow rate (mass 
and volume), density, temperature, pickoff coil amplitude, drive frequency, drive gain, and 
phase differential. Data logging information is written to a CSV file.

Note The Charts and Data Logging toolbar (Figure 3.1) will appear below the standard 
toolbar.

Start data logger

Stop data logger Exit 

Change chart refresh rate and logging interval 

Select to open real-time chart(s)

Figure 3.1—Charts and Data Logging toolbar

Data log files can be controlled using the following toolbar buttons:

 – Red Circle. Start recording to data logger (CSV file). Follow the screen prompts to 
choose the location for storing the file and change the filename, if desired.

 – Clock. Change the chart refresh rate and data logging interval (see below for 
details).

 – Black Square. Stop recording to data logger.
 – Black X. Close the chart and data logging toolbar.

Caution Before accessing the data file, verify that data logging is stopped by 
clicking the black square. If data logging is not stopped, EZ-Link soft-
ware may not be able to write the data to the designated file and the 
user may experience unexpected behaviors.

Changing the Data Sampling and Logging Interval
Data logging begins when you choose Process Variables>Charts and Data Logging> 
Recording>Start. The default logging interval is 3 seconds. To change the logging interval, 
click the clock icon on the Charts and Data Logging toolbar and use the slider bar to select 
the desired interval.

Available interval settings are:

 – 1 Second. Choosing this interval selects four variables (mass flow rate, drive gain, 
drive frequency, and right pickoff amplitude) for logging.

 – 2 Seconds. Choosing this interval selects eight variables (mass flow rate, volume 
flow rate, density, drive gain, drive frequency, right and left pickoff amplitudes, and 
sensor tube temperature) for logging.

 – 3 Seconds to 10 Minutes. Choosing this interval (shown in Figure 3.2 below) 
selects up to ten variables (mass flow rate, volume flow rate, density, drive gain, 
drive frequency, right and left pickoff amplitudes, sensor body temperature, sensor 
tube temperature, and phase differential) for logging. Sensor body temperature will 
only appear when communicating with a CamCor PRO Series meter.

Figure 3.2—Sample logging interval (3 seconds) dialog
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To save the interval change and exit the dialog, click OK. To exit without saving, click 
Close.

Viewing Charts
To view process variables and diagnostic values in the form of a chart, click the desired 
variable in the Charts and Data Logging toolbar. For example, click Mass Flow on the 
toolbar (Figure 3.1, page 18) to display mass flow data in a graph. The Mass Flow Rate 
chart (Figure 3.3) will appear. Charts for all other variables are selectable in the same 
manner. 

Figure 3.3—Mass Flow Rate chart

After opening a chart, EZ-Link will plot new data on a graph as it is sampled. Multiple charts 
can be viewed onscreen. For information about viewing multiple charts onscreen, see 
Windows Menu, page 39.

To adjust a chart’s scale, change the values in the “Maximum” and “Minimum” fields. Click 
OK to update the chart scale. To close the chart, click Mass Flow on the Charts and Data 
Logging toolbar.

Note All variable icons on the Charts and Data Logging toolbar have a toggle function, 
opening and closing a graph with each progressive click. Opening and closing 
charts has no effect on the data sampling and logging.

Viewing Write Protection Status

Write protection status indicates whether meter configuration parameters can be changed. 
If enabled, no changes can be written via any method, including EZ-Link, the LCD menu, 
Modbus communications, or HART communications. Additionally, most diagnostic tests 
cannot be executed. To check the write protection status, choose Process Variables> 
Write Protect. The Write Protect status screen (Figure 3.4) will appear.

Figure 3.4—Write Protect status screen

Either of two statuses will be displayed in the read-only dialog:

• Not write protected. Meter configuration can be modified and all tests can be run.

• Write protected. Meter configuration cannot be modified and most tests cannot be run.

Change Write Protection Status
Write protection status can be 
changed via the SW1 switch on the 
CPU board. For information about 
how to change the write protection 
status, consult the CamCor Coriolis 
Hardware Manual.
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Section 4—Diagnostics and Service
The CamCor transmitter has several built-in functions to assist with diagnostics and 
calibration. The Diagnostic/Service menu allows you to:

•    Perform diagnostic tests on the flowmeter and installation

•    Override each output for loop testing

•    Monitor the status input condition

•    Calibrate sensor readings

•    Calibrate analog outputs

•    Reset counter/totalizer(s)

Typically, the diagnostic and service dialogs cannot be displayed simultaneously, except for 
loop test and counter/totalizer control screens.

PERFORMING DIAGNOSTIC TESTS
There are two categories of diagnostic tests that may be performed:  Self Diagnostic and 
Installation. Self Diagnostic tests analyze the condition of the flowmeter, while Installation 
tests analyze the installation conditions used to determine if vibration or pulsation may be 
affecting meter performance.

Self-Diagnostics

The Self-diagnostics tests check the condition of the flowmeter. The four available tests are: 
hardware, drive coil, transmitter, and display, as shown in the menu structure in the Self-
Diagnostics sub-menu shown below:

Caution Except for the Display test, the Self-Diagnostics tests disrupt the flow 
measurements and affects output signals. Only execute self-diagnos-
tic tests when the flowmeter is not in service.

Hardware Test
1. Access the Hardware Test dialog (Figure 4.1, page 22) by choosing Diagnostic/

Service>Test/Status>Self Diagnostics>Hardware Test. 

Caution If the flowmeter outputs are used to control valves or other systems, 
place the control loop in Manual Control mode to isolate the transmit-
ter signal before changing the flowmeter configuration. Failure to do 
so may produce unexpected valve behavior or damage to the system. 
Additionally, potential safety and environmental hazards may occur.  
 
When changing the meter configuration, the analog/pulse outputs may 
become erratic or momentarily go to zero state before recovering. Af-
ter the configuration is updated, the transmitter will operate normally. 
Refer to the CamCor Coriolis Hardware Manual for details. 

Additional Instructions for 
Hardware Testing
In addition to the Hardware Test 
instructions here, the Hardware Test 
Start Confirmation dialog contains 
instructions. Follow both sets of 
instructions carefully. 
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Figure 4.1—Hardware Test dialog

2. Prepare for testing the hardware by following the instructions at the top of the dialog.

Note Each variable will be tested to validate whether it is within acceptable ranges.

3. Click OK and follow the onscreen prompts to begin testing the hardware related to the 
following items in the order listed below:

 – DSP voltage. Checks the internal DSP voltage. 
 – Input frequency. Checks the frequency of the drive coil.
 – Input phase differential. Checks the phase differential between the pickoff coils.
 – Input amplitude. Checks the signal amplitude of the pickoff coils. 
 – Input temperature. Checks the temperature measured by the RTD. 

If the hardware passes the test, OK will appear in the field provided. If issues are 
detected, FAIL will appear. 

4. If any hardware tests fail, Cameron recommends taking the following action(s):

 – DSP voltage. Consult Cameron. 
 – Input frequency. Run Drive Coil test and take action based on the results:

 ○ Pass. Consult Cameron.
 ○ Fail. Carefully verify the wiring connection between the sensor and the 

transmitter, then retest.
 – Input phase differential. Run the Transmitter test and take action based on the 

results:
 ○ Pass. Consult Cameron.
 ○ Fail. Carefully verify the wiring connection between the sensor and the 

transmitter, then retest.
 – Input amplitude. Run the Transmitter test and take action based on the results:

 ○ Pass. Consult Cameron.
 ○ Fail. Carefully verify the wiring connection between the sensor and the 

transmitter, then retest.
 – Input temperature. Run the Transmitter test and take action based on the results:

 ○ Pass. Consult Cameron.
 ○ Fail. Carefully verify the wiring connection between the sensor and the 

transmitter, then retest. 

5. Follow the screen prompts to acknowledge completion and exit the hardware self-test.

Drive Coil Test
The drive coil test checks the resistance of the drive coil. 

1. Choose Diagnostic/Service>Test/Status>Self Diagnostics>Drive Coil Test to ac-
cess the Drive Coil Test dialog.

IMPORTANT Carefully read the Caution statement on page 4.
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2. Prepare for testing the Drive Coil by following the instructions at the top of the dialog 
(Figure 4.1, page 22) and click OK to start testing.

3. If the Drive Coil resistance passes, OK will appear in the filed provided. If issues are 
detected, FAIL will appear.

4. If the Drive Coil test fails, Cameron recommends checking the wiring connection 
between the sensor and the transmitter. If the wiring is correctly connected, consult 
Cameron. If the wiring is disconnected, connect the sensor and retest.

Note If the Hardware test failed but the Drive Coil test passed, consult Cameron.

5. Follow the screen prompts to complete the test and exit the dialog.

Transmitter Test

1. Choose Diagnostic/Service>Test/Status>Self Diagnostics>Transmitter Test to 
access the Transmitter Test dialog.

IMPORTANT Carefully read the Caution statement on page 4.

Figure 4.2—Sample Transmitter Test dialog

2. Prepare for testing the Drive Coil by following the instructions at the top of the Trans-
mitter Test dialog (Figure 4.2).

3. Click OK and follow the onscreen prompts to begin testing the transmitter status in the 
order below:

 – RTD Connection. Checks the RTD connection.
 – Pickoff Connection. Checks the right and left pickoff coil connections.
 – Drive Coil Connection. Checks the drive coil connection.
 – EEPROM. Checks the EEPROM.
 – Data Update. Checks the communication between processors.
 – Transmitter Temperature. Checks the transmitter internal temperature.

4. If the category passes, OK will appear in the field to the right If issues are detected, 
FAIL will appear.

5. If any of the transmitter status tests fail, Cameron recommends taking the following 
action(s):

 – RTD Connection, Pickoff Connection or Drive Coil Connection. Carefully check 
the connection between the sensor and the transmitter.

 ○ Connected properly. Consult Cameron.
 ○ Disconnected. Connect the sensor and the transmitter, then retest.

 – EEPROM or Data Update. 
 ○ Pass. Device can be safely used if all other tests are successful.
 ○ Fail. Consult Cameron.
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 – Transmitter Temperature. 
 ○ Exceeds Temperature Rating. Check the ambient temperature and the 

device’s exposure to direct sunlight. If the ambient temperature exceeds the 
transmitter’s temperature rating and the transmitter is exposed to direct sunlight, 
create a sunshade or relocate the transmitter, wait for the transmitter to cool 
down, then retest.

 ○ Does Not Exceed Temperature Rating. If the ambinet temperature does not 
exceed the transmitter temperature rating and the transmitter is not exposed to 
direct sunlight, consult Cameron.

Note If the Hardware test failed but the Transmitter test was successful, consult Cam-
eron.

6. Follow the screen prompts to complete testing and exit the dialog.

Display Test
The display test checks the backlight, LED, and LCD. 

1. Choose Diagnostic/Service>Test/Status>Self Diagnostics>Display Test to access 
the Display Test dialog.

IMPORTANT Test results are visible on the transmitter display only. Therefore, a  
 person must be at the display during testing to report test results.

2. Click the radio button to the left of the test to be performed:

• Backlight. Cycles between white, orange, and off two times.

• LED. Cycles between red and green LEDs five times.

• LCD. Cycles between darkest contrast and lightest contrast two times.

3. Click CLOSE to exit the dialog.

Installation

The installation tests provide a way to diagnose the installation condition against vibration 
and pulsation. Because the CamCor meter uses the sensor vibration to measure flow, 
vibration or pulsation from external sources may adversely affect measurement accuracy. 

Caution The Installation tests disrupt the flow totalization and output. However, 
this does not prevent tests from being run with the meter in service.

Static Test for Pipeline Vibration
The Static Test for Pipeline Vibration monitors sensor readings and checks for noise 
caused by the external vibration, such as from the pipeline. Flow through the meter sensor 
must be blocked to run this test. If external vibration is detected, it may affect the meter 
performance. To achieve the lowest measurement uncertainty, the external vibration should 
be eliminated as much as is possible. 

IMPORTANT Analog outputs and pulse outputs are suspended during installation  
 testing. Take appropriate precautionary actions to avoid data loss.

1. To perform the static test, choose Diagnostic/Service>Test/Status>Installation> 
Static Test for Pipeline Vibration. 

2. Follow the instructions at the top of the Static Test for Pipeline Vibration dialog, then 
follow the screen prompts to perform the test.

3. Upon completion, look for the results in the bottom left corner of the screen, as shown 
in Figure 4.3, page 25.

Interrupted Tests
If one display test is started while 
another display test is running, the 
first display test will be cancelled 
and the new display test will begin.

Analog Output 1 and Loop 
Current Mode Override
When the Loop Current mode is set 
to “Disabled,” the Analog Output 
cannot be overridden.

A Multi-Drop Mode Warning 
notification may appear.
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Figure 4.3—Static Test for Pipeline Vibrations test results

Possible static test results and Cameron recommended actions are as follows:

• Best Condition. OK to use meter. • Good Condition. OK to use meter for 
majority of applications.

• Fair Condition. Acceptable to use 
meter. However, installation review 
and configuration adjustment to 
reduce uncertainty are recommended.

• Poor Condition. Review the installation 
and mitigate the noise before using 
meter.

Caution Operating under poor conditions can impair meter performance.

4. Click Close to exit the dialog.

Flowing Test for Pulsation
The Flowing Test for Pulsation monitors sensor readings and checks for noise caused by 
media pulsation, such as liquid flow downstream of a reciprocating pump. The pulsation 
may affect measurement uncertainty. To reduce uncertainty, the pulsation should be 
eliminated as much as possible.

IMPORTANT Analog outputs and pulse outputs are suspended during installation  
 testing. Take appropriate precautionary actions to avoid data loss.

1. To perform the flowing test, choose Diagnostic/Service>Test/Status>Installation> 
Flowing Test for Pulsation. 

2. Follow the instructions at the top of the Flowing Test for Pulsation dialog, then follow 
the screen prompts to perform the test.

3. Upon completion, look for the results in the bottom left corner of the screen, as shown 
in Figure 4.4.

Figure 4.4—Flowing Test for Pulsation test results

• Stable Flow. Measurement accuracy is reliable. Use the meter in this condition.

• Fairly Stable Flow. Measurement accuracy is reasonable, but not as good as the 
“Stable Flow” result. The meter can be used in this condition.

• Unstable Flow. Measurement accuracy is degraded or impaired by the meter’s 
exposure to extreme vibrations under non-flowing condtions.
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Caution If multiple Flowing Test results are “Unstable Flow,” increasing the 
Flow Rate Damping may help stabilize the flow rate measurement.  
 
Cameron recommends mitigating vibrations and pulsations before 
increasing the Flow Rate Damping, if possible.  If you cannot mitigate 
vibrations any longer, relocate the flowmeter to a different location in 
the process or install pulsation damping equipment to the pipeline to 
reduce vibration and pulsation.

4. Click Close to exit the dialog.

LOOP TEST
Loop Test functions are used to verify 
the wiring, the transmitter output signal 
levels, or the input status.

Access loop test functions by choosing 
Diagnostic/Service>Loop Test and 
selecting from the override and status 
input selections.

Analog Output (1 and 2)

When the Analog Output mode is overridden, the output signal from the specified port 
is overridden with the user-selected value. You must isolate the selected port from the 
control system before enabling the override mode. You can use the override mode to verify 
detection of an analog signal and the signal level and calibrate the analog inputs on another 
device.

Caution If the flowmeter outputs are used to control valves or secondary 
devices, place the control loop in Manual Control mode to isolate 
the transmitter signal before changing the flowmeter configuration. 
Failure to do so may produce unexpected valve behavior or system 
damage, which could pose potential safety or environmental hazards.

1. Click Diagnostic/Service>Loop Test>Override: Analog Output #. The Override: 
Analog Output # dialog (Figure 4.5, left) will appear.

  
Figure 4.5—Override: Analog Output before simulation (left) and during simulation (right)

2. Select a simulated output value. To enter a custom value, click “Other,” enter an analog 
value, and click Start (Figure 4.5, right).

3. Click Stop or Close the window to end the analog loop test.

Pulse Output (1 and 2)

When the Pulse Output mode is overridden, the output signal from the specified port is 
overridden with the user-selected settings. You must isolate the selected port from the 
control system before enabling the override mode. You can use the override mode to verify 
detection of a pulse signal on another device.

Analog Output 1 and Loop 
Current Mode Override
When the Loop Current mode is set 
to “Disabled,” the Analog Output 
cannot be overridden.

A multidrop mode warning may 
appear.
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Caution If the flowmeter outputs are used to control valves or other systems, 
place the control loop in Manual Control mode to isolate the transmit-
ter signal before changing the flowmeter configuration. Failure to do 
so may produce unexpected valve behavior or damage to the system. 
Additionally, potential safety and environmental hazards may occur.  

Caution Before enabling the Pulse Output Override mode, notate the cor-
responding Counter/Totalizer data. Once the Pulse Output data is 
overridden, the Counter/Totalizer will be updated as the transmitter 
outputs the pulse signals.

1. Click Diagnostic/Service>Loop Test>Override: Pulse Output #. The Override: 
Pulse Output # dialog (Figure 4.6, left) will appear.

  
Figure 4.6—Override: Pulse Output before simulation (left) and during simulation (right)

2. Select the desired output frequency. If a frequency other than 10,000 Hz is desired, 
click Other and enter the desired frequency in Hertz (0.1 to 11,000 Hz).

3. Enter the number of pulses desired.

4. Click Start to begin the simulation (Figure 4.6, right). Note that the secondary device 
should read the same frequency (Hz) as specified in the Override: Pulse Output dialog.

5. When the test is finished, the pulses received by the secondary device should match 
the pulses generated by the CamCor meter. Click Stop to disable the override and end 
the test.

6. Click OK to close the confirmation dialog. If a control system was placed in Manual 
mode prior to the test, you can switch the system back to Auto mode. 

Status Output

When Status Output is set to “Override” mode, the output signal from the port is overridden 
with the user-specified state. You can use the override mode to verify detection of a discrete 
signal on a secondary device.

Caution If the flowmeter outputs are used to control valves or other systems, 
place the control loop in Manual Control mode to isolate the transmit-
ter signal before changing the flowmeter configuration. Failure to do 
so may produce unexpected valve behavior or damage to the system. 
Additionally, potential safety and environmental hazards may occur.

1. Click Diagnostic/Service>Loop Test>Override: Status Output. The Override: Sta-
tus Output dialog (Figure 4.7, left) will appear.

More About the Override Pulse 
Output Dialog
If Target is set to “0,” the pulse 
output will produce the frequency 
specified at the top of the dialog 
until you end the test by clicking 
Stop or closing the dialog. 

If the Target is set to any value >0, 
the meter will produce the target 
pulses, then stop.  

Output Duration = Target Pulses / 
Frequency / (10.24 * 103) sec
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Figure 4.7—Override Status Output before simulation (left) and during simulation (right)

2. Choose Open or Closed as the simulated status output and click Start to enable the 
simulated output.

During simulation, the status message (Figure 4.7, right) appears at the bottom of the 
dialog.

3. Follow the screen prompts to continue or exit the simulation.

Monitoring the Status Input State

To monitor the status input state, click Diagnostic/Service>Loop Test>Status Input. The 
Status Input screen (Figure 4.8) will appear, displaying the status input state as “Closed” or 
“Open.”

Figure 4.8—Status Input screen

Test the Status Input by applying and removing a jumper across the two Status Input 
terminal strip connections, which should cause the state to toggle between open and 
closed. For more information about configuring the status input, see Status Input, page 
12.

CALIBRATION

IMPORTANT The improper calibration condition/procedure can impair measurement  
 accuracy. Before calibration, ensure the sensor is fully filled with a  
 single-phase process fluid and that the isolation valves are positively  
 sealed with no leakage. To avoid gas breaking out of the solution,  
 maintain the process fluid at a constant temperature. Do not expose the  
 meter to external vibrations.

Although the factory calibration will typically provide for accurate measurement, you might 
improve accuracy by executing a field calibration during commissioning or when the fluid 
properties have changed significantly. Since calibration is one of the most important factors 
to measure the fluid accurately, IMPORTANT warnings should be understood and adhered 
to. Even a small leakage during the calibration will impair the accuracy of the flow meter.

Before performing a field calibration, back up the current configuration by saving the meter 
configuration file. If the new field calibration results in the loss of accuracy, you can recover 
the old calibration by uploading the saved calibration file.

Auto Zero

The Auto Zero function adjusts the zero point of the meter transmitter by adjusting the bias 
of the flow meter.

Before performing an auto zero calibration,

1. Ensure that meter sensor tubes are completely filled with process fluid that is at a 
stable temperature. Unstable fluids can change state, resulting in adverse conditions.

Valve Sealing Check
After valves are closed and before 
performing the zero calibration, 
check for positive valve sealing. 

Select Setup>Device Variables 
and enter “0.0” in the Flow Rate 
Cutoff field.

Select Process Variables>View 
Device Variables 1 and observe 
the mass flow rate, which should be 
stable and have a value near “0.00.” 
If not, a leaky valve, unstable fluids, 
or a poor previous zero calibration 
are indicated.

After auto zeroing, return to Setup> 
Device Variables and load the 
original value in the Flow Rate 
Cutoff field.
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2. Positively seal upstream and downstream valves and ensure there is no leakage 
through the isolation valves. Any leakage can result in the loss of meter performance. 

  
Figure 4.9—Sample Auto-Zero Calibration screen (left) and status indicator (right)

3. To access the Auto Zero Calibration screen (Figure 4.9, left), choose Diagnostic/
Service>Calibration>Auto Zero. 

4. Follow the instructions at the top of the screen.

5. Click OK and follow the screen prompts to complete auto zeroing. During auto zeroing, 
“Adjusting, Please wait...” appears in the bottom left of the screen, as shown in Figure 
4.9, right.

Upon completion, the statistical data (mean, minimum, and maximum) that were measured 
during calibration will appear onscreen.

Density Calibration (Liquid)

The factory calibration for density uses purified water and accounts for low uncertainty 
measurement a wide range of fluid densities. However, in the event the density of process 
fluid varies significantly from the density of water, you may reduce the uncertainty by 
performing the density calibration.

IMPORTANT For density calibrations, the exact density of fluid must be precisely  
 known and significantly more dense than air. The meter sensor tubes  
 must be completely filled with fluid. During the calibration, the fluid  
 condition, including the density and the temperature, must be stable, with  
 no flow or leakage is allowed. Refer a recognized standards for more  
 details how to extract and handle a sample as a reference fluid for the  
 calibration.

Before performing a field density calibration,

1. Download the meter configuration to preserve the factory density calibration. In the 
event that the field density calibration results in a loss of meter performance, you can 
restore the factory density calibration by uploading the configuration file. 

2. Refer to a recognized standard (such as ASTM or ISO) for guidance in the methods of 
extraction and handling of a sample to use as a reference fluid. 

Factory Density Calibration
Factory density calibrations are 
performed in a highly-controlled 
environment, using purified fluids, 
long settling times, stable fluid, and 
a constant ambient temperature.  
These conditions are difficult to 
replicate in the field.
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Figure 4.10—Sample Density Calibration (Liquid) screen

3. To access the Density Calibration (Liquid) screen (Figure 4.10), choose Diagnostic/
Service>Calibration>Density (Liquid). 

4. Enter the exact known density value of fluid (g/mL) in the field at the top of the screen.

5. Click OK and follow the screen prompts to complete calibration. During calibration, 
“Adjusting, Please wait...” appears in the bottom left of the screen, as shown below.

Upon completion, the statistical mean, minimum, and maximum measured during 
calibration will appear onscreen.

OUTPUT CALIBRATION
The analog outputs on the transmitter are factory calibrated, ensuring reasonable accuracy 
for most users. Output calibration allows you to fine tune the 4 to 20 mA output by 
generating a fixed 4 mA signal and a fixed 20 mA signal that can be read by a precision 
ammeter to ensure output accuracy. Deviation from the ammeter’s values can be trimmed 
in the CamCor meter, allowing precise outputs to secondary devices during normal 
operations.

IMPORTANT If the flowmeter’s output is used to control valves or secondary devices,  
 change that control loop to manual control so that the loop is not affected  
 by the flowmeter’s output.

1. Connect the precision ammeter to the appropriate analog output terminals. 

2. Access the Adjust Analog Output # dialog (Figure 4.11), choose Diagnostic/Service> 
Calibrate Output - Analog Output #.

Figure 4.11—Calibrate Output - Analog # Range Selection dialog

3. Select the desired range (“4 mA to 20 mA” or “Other Scale”) and click OK.

Analog Output 1 Calibration and 
the Loop Current Mode
When the Loop Current mode is set 
to “Disabled,” the Analog Output 
signal cannot be calibrated.

A Multi-Drop Mode Warning 
notification may appear.

Shunt Resistance
When the secondary device 
requires a voltage input, a shunt 
resistor is required to convert 
the current output to a voltage 
output. The shunt resistor may be 
embedded in the secondary device,  
installed across the terminals at the 
CamCor output, or at the secondary 
device input.   

The resistance required depends 
on the voltage range. For 1 to 5 V, 
the resistance would be 250 ohms, 
which is calculated as follows:

Voltage leVel: 

Resistance * 4 / 1000  (at 4 mA 
output)

Resistance * 20 / 1000 (at 20 mA 
output)

external Shunt reSiStance:

1 V / 4 * 1000   (at 4 mA output)

5 V / 20 * 1000  (at 20 mA output)
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4 mA to 20 mA Calibration

To calibrate the output of a 4 mA to 20 mA scale, select 4 mA–20 mA and click OK twice to 
enter the calibration mode. The Calibrate Output - Analog # dialog (Figure 4.12) will appear.

Figure 4.12—Calibrate Output - Analog # (4 mA) dialog

1. When the reading on the precision ammeter stabilizes, enter the reading in the 4 mA 
Output Reading field.

2. Click OK. The CamCor meter will internally adjust to increase or decrease the output 
current to stabilize the signal at 4 mA. The ammeter should now read “4 mA.”

3. Verify that the precision ammeter reading is 4 mA.

4. If necessary, repeat steps 1 through 3 to fine tune the 4 mA output. 

5. Click on the 20 mA tab and repeat steps 1 through 3.

6. If necessary, repeat steps 1 through 3 to fine tune the 20 mA output.

7. Click Close, then OK, to return the meter to normal operation.

Other Scale Calibration

To adjust the output to a scale in VDC, wire a precision shunt resistor and a precision 
voltmeter across the analog output terminals. The most common voltage output is 1 to 5 
VDC, which requires a 250 ohm resistor. 

Note If a different voltage range is required, select the appropriate resistor. 

1. From the Calibrate Output – Analog # dialog (Figure 4.11, page 30), select Other 
Scale and enter the minimum value in VDC that corresponds to 4 mA (span low point). 
The upper value will be adjusted automatically.

2. Click OK twice to accept the range values and enter the calibration mode.

3. When the reading on the precision voltmeter stabilizes, enter the voltmeter reading in 
the 4-mA Output Reading field on the 4 mA tab.

4. Click OK. The CamCor meter will internally adjust to increase or decrease the output 
signal to make the voltmeter indicate the correct voltage, as assigned to the span low 
point.

5. Verify the precision voltmeter is reading the correct voltage, as assigned to the span 
low point.

6. If necessary, repeat steps 3 through 5 as necessary to fine tune the output signal. 

7. Click the 20 mA tab and repeat steps 3 through 5 to fine tune the span high point.

8. Click Close, then OK, to return the meter to normal operation.
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COUNTER/TOTALIZER CONTROL
To pause or reset the Counter/Totalizer, 

1. Choose Diagnostic/Service>Counter/Totalizer Control>Counter/Totalizer Con-
trol #. The Counter/Totalizer Control # dialog (Figure 4.13) will appear.

  
Figure 4.13—Counter/Totalizer Control # dialog, counting (left) and paused (right)

2. Pause the counter by clicking Stop, which will change the green “Counting” status 
indicator (Figure 4.13, left) to red, indicating a “Paused” status (Figure 4.13, right).

3. To resume counting, click the Start button.

4. To reset the pulse counters and flow totalizers to zero, click Reset. After the reset, the 
counter wil immediately resume operation. Click Close to exit.

Note Clicking Close while the counter is paused will automatically return the counter/
totalizer to the “Counting” state.
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Section 5—Maintenance
The Maintenance menu provides tools that are useful in maintaining the flowmeter. From 
this menu, you can

• View and save event, user change, and 
transmitter temperature logs

• View transmitter temperature 

• Check total runtime

• Change device time and date

• Simulate outputs (measurement variables)

• Reboot the device

• View the configuration change counter

LOGS
To access the following logs, choose Maintenance>Transmitter>[Log Type] Log. 

• Event log

• User Change log

• Transmitter Temperature log

Event Log

The Event Log displays critical events, such as alarms, calibrations, errors and status 
checks. The transmitter retains approximately 1,400 log entries. When no more space 
isavailable, the oldest log entries are overwritten with the newest log entries. Use the Event 
Log when troubleshooting erratic meter performance.

As soon as Maintenance>Transmitter>Event Log is selected, the Event Log appears and 
Event Log entries are automatically loaded, beginning with the most recent entries. To stop 
the older events from loading, click Stop Loading. A countdown message in the lower left 
of the screen indicates how long until the log stops loading.

To cancel the loading of the log, click Stop Loading and note the countdown message 
in the lower left corner of the screen. The cancel function can take several seconds to 
complete (Figure 5.1). 

Figure 5.1—Event Log
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To delete all entries in the log, click Clear Log. To reload the most recent events, click 
Reload Log. To save the log entries to a CSV file, click Save and select a storage location. 
Click Close to exit.

User Change Log

The User Change Log (Figure 5.2) displays the user changes (units of measure, alarm 
parameters, low flow cutoff, etc.) to the meter configuration. The entries are time and date 
stamped and include the “before” and “after” values. The transmitter retains approximately 
220 log entries. When no more space is available, the oldest log entry is overwritten with 
the newest log entry.

As soon as Maintenance>Transmitter>User Change Log is selected, the User Change 
Log is displayed and entries are automatically loaded, beginning with the most recent 
entries. To stop the older events from loading, click Stop Loading.

Figure 5.2—User Change Log

To reload the User Change Log, beginning with the most recent entries, click Reload Log. 
To save the displayed log entries to a CSV file, click Save and select a storage location. 
Click Close to exit.

Transmitter Temperature Log

The Transmitter Temperature Log (Figure 5.3) displays the transmitter internal temperature 
log. The transmitter logs the temperature every two minutes and retains approximately 
64 log entries. When no more space is available, the oldest log entry is overwritten with 
the newest entry. If the internal temperature exceeds 194 degF (90 degC), a transmitter 
temperature alarm occurs. Only 32 log entries will be recorded after the alarm and no 
additional entries will be logged until the unit is reset.

Figure 5.3—Transmitter Temperature Log

34



To reset the transmitter temperature alarm and restart logging, 

1. Click Reset, and click OK in the dialog that appears (shown in Figure 5.4).

Figure 5.4—Transmitter Temperature Log reset dialog

2. To reload the Transmitter Temperature Log, click Reload Log.

3. To save loaded logs into CSV file format, click Save and select a storage location.

4. Click Close to exit the log.

Transmitter Temperature

To view the transmitter’s current internal temperature, choose Maintenance>Transmitter> 
Transmitter Temperature. The Transmitter Temperature screen (Figure 5.5) will appear. 
Click Close to exit.

Figure 5.5—Transmitter Temperature screen

Device Time and Date

To view total operating time or change the date and/or time, choose Maintenance> 
Transmitter>Device Time and Date to access the Device Time and  Date dialog (Figure 
5.6).

Figure 5.6—Device Time and Date dialog

Total Runtime is a read-only display that can be used to prompt replacement of the 
transmitter as a preventative maintenance measure. Users can configure the unit to display 
an indicator on the LCD when the Total Runtime reaches 100,000 operating hours (over 
11 years). For more information about indicator configuration, see the CamCor Coriolis 
Hardware Manual. 

To change the date or time, click in the appropriate fields and enter new values for month-
day-year or hour-minute-second. Click OK to save changes or Close to exit without saving 
changes.

Note The device does not have an onboard battery back-up circuit.

Date/Time Log Discrepancies
When you change the date and 
time, the values are reflected in the 
log data. However, in the event the 
unit loses power, the transmitter will 
not retain the user-specified data 
for time and date. Upon return of 
power,  the transmitter will overwrite 
the time and date with a special 
entry to indicate the power loss 
event.
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SIMULATED OUTPUTS
Simulated Outputs are used to simulate critical measurement variables, overriding 
calculation results from sensor readings. When enabled, the transmitter uses the 
overwritten values to display and output the signals. To avoid the erratic behaviors, the 
overridden values shall be within sensor ranges. Use this maintenance mode to check the 
scaling at the secondary device or output signals at the specific flow condition. To configure 
the Simulated Output mode, perform the following steps:

1. Choose Maintenance>Simulated Outputs. The Simulated Outputs dialog (Figure 
5.7) will appear.

Figure 5.7—Simulated Outputs dialog

2. Enter override values, which should be within the meter’s upper and lower range limits, 
in the fields provided. (For information about setting units of measure, see Device 
Variables, page 4.)

3. Select Enabled from the “Override Status” dropdown menu, then click OK and follow 
the instructions on the screen. With override enabled, the transmitter will override the 
measurement variables with specified values until you disable the override status.

4. To terminate simulated outputs, select Disabled from the “Override Status” dropdown, 
then click OK and follow the onscreen instruction.

IMPORTANT If you do not disable the Override Status, the transmitter will continue to  
 display and output the simulated override values. The Close button will  
 NOT end the override function.

5. To close the Simulated Outputs dialog, click Close.

DEVICE RESET
The transmitter can be rebooted without power cycling using the Device Reset function. By 
rebooting, the transmitter may improve communication and resolve lagging communication 
issues. 

IMPORTANT A device reboot should not be activated for any reason other than  
 maintenance purposes. Immediately aftter reboot, the transmitter will  
 initiate the Boot Up Test procedure. Should any test parameter fail, further  
 measurements will be paused until the issue is resolved and the unit is  
 rebooted again.

To perform a soft reboot of the device, choose Maintenance>Device Reset to access the 
Reboot Device screen (Figure 5.8), then click OK and follow onscreen prompts.
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Figure 5.8—Reboot Device screen

To cancel the soft reboot or to exit the screen, click Close.

CONFIGURATION CHANGE COUNTER
The Configuration Change Counter provides a cumulative numeric value that represents 
the number of changes made to the meter configuration via the HART interface. 

The Configuration Change Counter dialog provides a method for acknowledging changes 
initiated through a  HART interface. If you are not using a HART host, the Configuration 
Change Counter dialog only provides the method to check the number of changes made 
through a HART interface.

Note If the Configuration Change Counter dialog is open and changes are made, the 
counter will not automatically update.

View the counter as follows:

1. Choose Maintenance>Configuration Change Counter. The Configuration Change 
Counter dialog (Figure 5.9) will appear.

Figure 5.9—Configuration Change Counter dialog

2. If you are using a HART host, the Configuration Change Counter dialog provides a 
method to reset Configuration Change Bit to acknowledge the changes through HART. 
From the Configuration Change Counter dialog (Figure 5.9).

Click OK on the Configuration Change Counter dialog. The Configuration Change 
Counter reset confirmation message (Figure 5.10) will appear. Click OK. EZ-Link will 
send the value displayed on the screen as “Number of Changes” to the transmitter.

Figure 5.10—Configuration Change Counter reset confirmation message

3. If the number of changes on the transmitter matches the number sent by the EZ-Link, 
the Configuration Changes Bit will be reset successfully. If the number of changes do 
not match, Configuration Change Counter Mismatch error message (Figure 5.11, page 
38) will appear. Click OK and Reload to read the Configuration Change Counter 
from the transmitter.  Repeat step 2 to acknowledge the configuration changes and to 
reset the Configuration Change Bit.
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Figure 5.11—Configuration Change Counter Mismatch error message
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Section 6—Additional Information and Help

WINDOWS MENU
The Windows menu allows you to arrange open screens in the workspace. Available 
arrangements are cascade, tile horizontally, and tile vertically.

HELP MENU
The following items are stored in the Help menu:

• User manuals, including hardware, software, and Modbus protocol manuals

• About screen, which displays the software version number and provides access to 
Technical Support contact information
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WARRANTY - LIMITATION OF LIABILITY:  Seller warrants only title to the products, software, supplies and materials and that, except as to software, the 
same are free from defects in workmanship and materials for a period of one (1) year from the date of delivery.  Seller does not warranty that software 
is free from error or that software will run in an uninterrupted fashion.  Seller provides all software “as is”.  THERE ARE NO WARRANTIES, EXPRESS 
OR IMPLIED, OF MERCHANTABILITY, FITNESS OR OTHERWISE WHICH EXTEND BEYOND THOSE STATED IN THE IMMEDIATELY PRECEDING 
SENTENCE.  Seller’s liability and Buyer’s exclusive remedy in any case of action (whether in contract, tort, breach of warranty or otherwise) arising 
out of the sale or use of any products, software, supplies, or materials is expressly limited to the replacement of such products, software, supplies, or 
materials on their return to Seller or, at Seller’s option, to the allowance to the customer of credit for the cost of such items.  In no event shall Seller be 
liable for special, incidental, indirect, punitive or consequential damages.  Seller does not warrant in any way products, software, supplies and materials 
not manufactured by Seller, and such will be sold only with the warranties that are given by the manufacturer thereof.  Seller will pass only through to 
its purchaser of such items the warranty granted to it by the manufacturer.
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